使用综合模块编程,人人都是技术大神
群主天启
楼主: 天启
查看: 502|回复: 0

[例程源码] 易语言汇编取字节集指针源码

[复制链接]
天启 发表于 2022-4-19 21:52:46 | 显示全部楼层 |阅读模式
本帖最后由 天启 于 2022-4-19 21:54 编辑
.版本 2

.子程序 取字节集指针, 整数型
.参数 字节集, 字节集
.局部变量 汇编, 控件_汇编

汇编.置入指令 (“mov eax, dword [ebp+0x08]”)
汇编.置入指令 (“mov eax, dword [eax]”)
汇编.置入指令 (“test eax, eax”)
汇编.置入指令 (“je label1”)
汇编.置入指令 (“add eax, 0x08”)
汇编.置入指令 (“leave”)
汇编.置入指令 (“retn 0x0004”)
汇编.置入指令 (“label1:”)
返回 (Call (汇编.取汇编指针 ()))

汇编可以绕过API的检测和约束,纯语法版
快速回复 返回列表 返回顶部